找回 Ubuntu Natty 里 Compiz 0.9.2.1 版本丢失的附加特效包

Compiz 更新到 0.9 虽然已经过去挺长时间了, 但是 Ubuntu 源似乎一直没有打算把 plugins-extra 也跟上更新到0.9.2.1版本. 搜索了一阵, 在 LinuxQuestion 找到了一个可行的编译方法以配合系统源里的compiz.
步骤:
1, 到 http://releases.compiz-fusion.org/0.9.2.1/ 下载合适版本的plugins-extra.
传送门: http://releases.compiz-fusion.org/0.9.2.1/compiz-plugins-extra-0.9.2.1.tar.gz

2, 解压之:

3, 执行下面的命令:

4, 编辑 CMakeCache.txt

5, 查找下面的内容:

替换为


6, 然后继续安装

7, 之后, 关闭compiz重新打开(或者注销/重登陆)后, ccsm里的plugins-extra就会全部回来啦!

8, 给懒人的方法:
访问 http://deb.felixcat.net 下载我编译好的包直接安装吧! (仅amd64)

参考资料: http://www.linuxquestions.org/questions/ubuntu-63/dependency-problems-when-installing-compiz-fusion-plugins-extra-in-11-04-pre-alpha-844230/

9 thoughts on “找回 Ubuntu Natty 里 Compiz 0.9.2.1 版本丢失的附加特效包”

  1. make的时候出现如下错误 怎么回事??

    — Configuring done
    — Generating done
    — Build files have been written to: /home/synci/Download/Compiz/compiz-plugins-extra-0.9.2.1/build
    [ 1%] Building CXX object firepaint/CMakeFiles/firepaint.dir/src/firepaint.cpp.o
    [ 1%] Building CXX object firepaint/CMakeFiles/firepaint.dir/__/generated/firepaint_options.cpp.o
    Linking CXX shared library libfirepaint.so
    /usr/bin/ld: cannot find -lGL
    /usr/bin/ld: cannot find -lGL
    collect2: ld returned 1 exit status
    make[2]: *** [firepaint/libfirepaint.so] Error 1
    make[1]: *** [firepaint/CMakeFiles/firepaint.dir/all] Error 2
    make: *** [all] Error 2

    1. $ dpkg -S /usr/lib/libGL.so
      libgl1-mesa-dev: /usr/lib/libGL.so

      于是你应该没有安装 libgl1-mesa-dev 这个库包, apt一下吧 🙂

  2. 话说Natty里不能直接sudo apt-get install compiz-fusion-plugins-extra 么?我好像可以的样子。

Leave a Reply

Your email address will not be published.